J3.x

Erweiterung kann nicht installiert werden

From Joomla! Documentation

Revision as of 11:02, 5 September 2021 by Franz.wohlkoenig (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Other languages:
Deutsch • ‎English • ‎Nederlands • ‎español • ‎français • ‎русский • ‎中文(中国大陆)‎
Joomla! 
3.4.0

Einige Erweiterungen lassen sich in Joomla! 3.4.0 mit der Meldung "No file selected. Unable to find install package" nicht installieren.

Berichtete Fehler

No file selected. Unable to find install package.

(Der Fehler ist sehr allgemein und kann bei vielen anderen Problemen ebenfalls zutreffen. Das ist jedenfalls der einzige angezeigte Benutzerschnittstellen-Fehler, der aus dem NUR Joomla! 3.4.0 betreffenden Problem resultiert).

Betroffene Versionen

Info non-talk.png
General Information

This pertains only to Joomla! version(s):- 3.4.0

Ursache

Für das Hinaufladen von Dateien in JFile::upload wurden zusätzliche Sicherheitsprüfungen in PHP-Dateien hinzugefügt. Leider wurden sie für den Erweiterungs-Installer nicht daktiviert, der unkompromierte zip-Dateien als unsicher interpretiert und damit nicht installiert.

Wie ist der Fehler zu lösen

Vor der Installation sicherstellen, dass die zip-Dateien richtig komprimiert sind.

Den Patch https://github.com/joomla/joomla-cms/pull/6180 verwenden (er ist in Joomla 3.4.1 enthalten).