Mes extensions Joomla! 2.5 vont-elles fonctionner avec Joomla! 3.x ?

From Joomla! Documentation

This page is a translated version of the page Will my Joomla! 2.5 extensions work with Joomla! 3.x? and the translation is 100% complete.

Other languages:
български • ‎Deutsch • ‎English • ‎español • ‎français • ‎Bahasa Indonesia • ‎Nederlands • ‎português • ‎русский
Joomla! 
3.x
série

Les extensions natives de Joomla! 2.5 devraient fonctionner sous Joomla! 3.0, avec peu de changement, le cas échéant. Les composants et templates demanderont du travail, alors que les modules et plug-ins devraient fonctionner sans problème (en supposant qu'ils n'utilisent pas de méthodes obsolètes). Les extensions pour Joomla! 2.5 et 1.5, empaquetées ensemble, ne devraient pas fonctionner tant que les développeurs ne les mettent pas à jour pour les rendre compatible avec Joomla! 3.

En bref, tout dépend de l'extension. Le Projet Joomla! a rendu le processus relativement simple pour la plupart des extensions, cependant, pour certaines extensions, cela demande une certaine quantité de travail. Pour être sur, faites connaître aux développeurs d'extensions l'utilisation que vous souhaitez faire de leur extension sous Joomla! 3 et consultez leur documentation.