Съображения относно шаблона/темплейта по време на миграция

From Joomla! Documentation

This page is a translated version of the page Template Considerations During Migration and the translation is 56% complete.

Outdated translations are marked like this.
Copyedit.png
This Article Needs Your Help

This article is tagged because it NEEDS UPDATING. You can help the Joomla! Documentation Wiki by contributing to it.
More pages that need help similar to this one are here. NOTE-If you feel the need is satistified, please remove this notice.

Reason: See section 3.4 and 4


Other languages:
български • ‎català • ‎Deutsch • ‎English • ‎español • ‎français • ‎Nederlands • ‎português do Brasil • ‎русский

Шаблоните/темплейтите в повече случаи поставят потребителите в неведение по време на миграцията. Това не трябва да е така. С малко обяснение всичко може да стане ясно и да знаете какви са вашите опции и възможности.

Начало

Шаблоните са приложения. Точно като компонентите, модулите и плъгините.

В настройките на миграцията трябва да решите какво ще правите с вашия настоящ шаблон(който определя настоящата визия на вашия сайт).

В по - голямата част от случаите, потребителите принадлежат към някоя от опциите описани долу:

  • Използвате шаблон, който сте взели със платен абонамент към даден разработчик
  • Използвате шаблон, който сте закупили еднократно от даден разработчик
  • Имате шаблон, който е направен/написан за Вас
  • Използвате стандартния шаблон, който е инсталиран с Joomla!(Joomla 1.5 стандартни шаблони - Rhuk_milkyway, JA Purity, Beez и Joomla! 2.5 стандартни шаблони - Atomic и две различни версии на Beez).

Изготвяне на вашия сценарий относно шаблона

Преди да вземате каквито и да било решения, първо помислете дали искате да запазите сегашната визия на настоящия уеб сайт. Ако искате да я смените сега е подходящия момент. Може би причината поради която ще искате да смените вашия шаблон/темплейт е възможността да използвате по - нови технологии, преимущества, функции в новите темплейти. Responsive шаблони не са налични в 1.5(освен ако не сте платили на някого да направи вашия 1.5 шаблон mobile-friendly) и дори в началото на 2.5, мобилните версии на шаблоните не бяха напълно responsive.

Нека да започнем сценария стъпка по стъпка:

You are using Protostar

Protostar is not compatible with Joomla 4.x. The migration will work on the one-click from Joomla 3.10.x to 4.x but the template will disappear and be replaced with Cassiopeia upon migration. You will need to plan on using Cassiopeia or some other template in Joomla 4.

Why can't you carry forward Protostar into Joomla 4?

Protostar is based on an old version of Bootstrap (Bootstrap 2) and jQuery (1.x). The versions of these components are outdated and have known security issues (Joomla 3 maintained forked versions of these libraries with security patches applied) - and Joomla 4 has updated these to the latest version - Bootstrap 5. However this means that templates need to be updated to use the new HTML syntax that Bootstrap 5 requires.

Използвате шаблон, който сте взели чрез абонамент към даден разработчик

Това е по - лесната част - в повечето случаи. Ако сте взели темплейта чрез закупуване на абонамент към разработчик, тогава проверете отново дали го има наличен и за Joomla 3.x. Ако го има - отлично, но има още няколко неща, за които да помислите. Ако използвате 1.5 и мигрирате до 3.x, проверете дали версията за Joomla 3 е responsive, ако това е важно за Вас. Ако използвате 1.5 и мигрирате до 3, има вероятност да има някои разлики между версията на шаблона за 1.5 и тази за 3. Бъдете готови да направите някои корекции по шаблона, ако е необходимо и ако искате да изглежда "точно" по същия начин.

Ако използвате 2.5 и мигрирате до 3.x, проверете дали версията за 2.5 и за 3.x са направени в един пакет от разработчика. Ако не са, трябва да проверите при разработчика дали има указание за мигриране от 2.5 до 3.x. Ако двете версии на шаблона са направени в един пакет, значи всичко е отлично, но това зависи основно от разработчика на шаблона.

Ако използвате шаблон, който сте закупили еднократно от даден разработчик

Ако имате шаблон, който сте закупили еднократно от даден разработчик първо проучете дали има версия за Joomla 3.x. Ако няма налична версия, тогава Вие вероятно нямате късмет. Може да се свържете с някой от компанията и да го запитате дали може да направи обновяването на шаблона, за да е съвместим с Joomla 3.x.

Ако и това не се получи, значи имате следните варианти:

  1. Изберете нов шаблон/темплейт
  2. Конвертирайте шаблона за да е съвместим с Joomla 3.x(Забележка: може би няма да е responsive)

Първия вариант е ясен сам по себе си. Може да изберете шаблон от даден разработчик или да си конфигурирате стандартния Protostar шаблон, който е наличен с всяка инсталация на Joomla 3.x. Вторият вариант обаче не е толкова лесен. За да разберете как да конвертирате вашия настоящ шаблон да е съвместим с Joomla 3, вижте следния раздел.

Мигриране на шаблони/темплейти

Мигриране на шаблон 1.5 към 3

Мигриране на шаблон 1.5 към 2.5

Мигриране на шаблон 2.5 към 3

3.10.x to 4 Template Conversions

This section needs content. If you have knowledge on converting templates built for Joomla 3 to make them compatible with Joomla 4, please write a magazine article or post a YouTube or something that can be linked from this area. Thanks in advance.

Имате шаблон, който е направен/написан за Вас

Ако имате шаблон, който е направен/написан за вашия 1.5 или 2.5 сайт е необходимо да бъде конвертиран и да е съвместим с Joomla 3. Погледнете връзките в предишната секция, а ако е нужно да наемете някой, който да ви помогне с това, погледнете в Joomla! Resource Directory:Управление на шаблона or Миграция и обновяване

Използвате стандартен шаблон, който е инсталиран с Joomla!

Стандартните шаблони на Joomla 1.5 са Rhuk_milkyway, JA Purity и Beez. На Joomla 2.5 са Atomic и две различни версии на Beez. Ако използвате стандартен шаблон на 2.5 и преминавате към 3.х ще можете с един клик да го обновите. Ако използвате стандартен шаблон на 1.5, тогава ще Ви е необходимо да преминете през стъпките по - горе за да преминете на Joomla 3.x.

Преди да решите, че желаете да конвертирате вашия 1.5 шаблон към Joomla 3, трябва да помислите дали не може да го замените с някой подобен, който е предназначен за Joomla 3. Шансовете са много по - големи, много по - бързо ще се получи ако използвате нов вместо да конвертирате стария. Ако все пак решите, че е необходимо да конвертирате стария, но нямате нужните умения за да го направите сами посетете Joomla! Resource Directory™.

Protostar, the template that ships with Joomla 3.x is not compatible with Joomla 4.x. You will need to go through one of the steps above to update it for Joomla 4.x.

При избор на темплейти

  • Погледнете само една компания разработчик за шаблони/темплейти иначе ще започнете да се обърквате
  • Ако вече сте започнали да се обърквате, вземете си почивка дори това да означава цял ден
  • Опитайте се да прегледате изцяло шаблона за негови функции и разновидности, защото сте на път да слагате вашата информация на него и не искате да откриете, че някоя функция липсва

Използване на стандартен шаблон Protostar в Joomla 3.x

Този раздел не е довършен. Ако имате познания относно тази тема, моля участвайте като ги добавите тук. Междувременно чрез Google търсене за Protostar шаблон ще намерите много резултати, които са извън Joomla! Docs.