¿Qué versión de Joomla! debería usar?

This page is a translated version of the page What version of Joomla! should you use? and the translation is 100% complete.

Other languages:
العربية • ‎български • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский

Antes que nada, puede ser que quieras comprobar la versión de Joomla! sobre la que corre tu sitio web.

Compruebe cuál es la última versión del CMS Joomla. Si no está usándola, lea las notas de la versión para ver si necesita actualizar. Si una versión está siendo creada para resolver un problema de seguridad entonces se recomienda encarecidamente actualizar tan pronto como sea posible. Puede ver el histórico de versiones de cada rama en la tabla que hay a continuación. Haga clic en el enlace al histórico de la versión en la columna de notas para encontrar detalles sobre la fecha exacta del lanzamiento, notas de la versión y paquetes y MD5s.

  • Normalmente, deberías usar la última versión de Joomla! para un sitio nuevo a menos que tengas una razón concreta para no hacerlo.
  • Asegúrate de suscribirte al canal electrónico Anuncios de Seguridad de Joomla!. Este canal RSS se usa para hacer anuncios, incluyendo la disponibilidad de nuevas versiones, que podrían afectar a la seguridad de tu sitio. Tienes la opción de suscribirte a este canal a través de RSS o correo electrónico.
  • Si estás ejecutando una versión anterior a la actual (por ejemplo, si estás usando la 3.1.6 y la actual es la 3.4.1), deberías actualizar a esta última. Cada versión menor soluciona una serie errores y/o problemas de seguridad. Siempre es una buena práctica actualizar a la última versión de mantenimiento como primer paso en la solución de un problema y en la solución de cualquier problema de seguridad recién detectado.

Versiones del CMS Joomla!

Versión del CMS Disponible Soporte Fin de vida útil (EOL) Tipo de actualización Notas Última versión
Bugs Seguridad
1.0
X-mark.png
X-mark.png
X-mark.png
22 de julio de 2009 Migración a 1.5 Plantéate migrar a la 1.5 hoy mismo EOL en la 1.0.15
1.5
X-mark.png
X-mark.png
X-mark.png
Sept 2012 Migración a 2.5 Plantéate migrar a la 2.5 hoy mismo
Histórico de versiones de Joomla! 1.5
EOL en la 1.5.26
1.6
X-mark.png
X-mark.png
X-mark.png
Ago 2011 Con un solo clic a 2.5 Actualiza a la 2.5 hoy mismo
Histórico de versiones de Joomla! 1.6
1.6.6
1.7
X-mark.png
X-mark.png
X-mark.png
Feb 2012 Con un solo clic a 2.5 Actualiza a la 2.5 hoy mismo
Histórico de versiones de Joomla! 1.7
1.7.5
2.5
X-mark.png
X-mark.png
X-mark.png
31 de Diciembre de 2014 Con un clic a la 3.x Actualiza a 3.8.1 ahora mismo
Histórico de versiones de Joomla 2.5
2.5.28
3.0
X-mark.png
X-mark.png
X-mark.png
May 2013 Con un solo clic a 3.1 Deberías usar la actualización en un clic
Histórico de versiones de Joomla 3.0
3.0.4
3.1
X-mark.png
X-mark.png
X-mark.png
Dic 2013 Con un solo clic a 3.2 Deberías usar la actualización en un clic
Histórico de versiones de Joomla 3.1
3.1.6
3.2
X-mark.png
X-mark.png
X-mark.png
Oct 2014[1] Con un solo clic a 3.3 Deberías actualizar el PHP de tu servidor a la versión 5.3.10 o superior y actualizar a la 3.3
Histórico de versiones de Joomla 3.2
3.2.7
3.3
X-mark.png
X-mark.png
X-mark.png
Versión 3.4 Con un clic Deberías usar la actualización en un clic
Histórico de versiones de Joomla 3.3
3.3.6
3.4
X-mark.png
X-mark.png
X-mark.png
Versión 3.5 Con un clic Recomendada para todas las nuevas instalaciones
Histórico de versiones de Joomla! 3.4
3.4.8
3.5
X-mark.png
X-mark.png
X-mark.png
Versión 3.6 Con un clic Recomendada para todas las nuevas instalaciones
Histórico de versiones de Joomla! 3.5
3.5.1
3.6
X-mark.png
X-mark.png
X-mark.png
Versión 3.7 Con un clic Recomendada para todas las nuevas instalaciones
Histórico de versiones de Joomla! 3.6
3.6.5
3.7
X-mark.png
X-mark.png
X-mark.png
3.8 release One-click Recommended for all new installs
Joomla! 3.7 version history
3.7.5
3.8
Checkmark.png
Checkmark.png
Checkmark.png
3.9 release One-click Recommended for all new installs
Joomla! 3.8 version history
3.8.1
3.9[2] to define[2][3] - - 2 years after the release of 3.9.0, marks end of support for 3.x One-click
4.0

2016

[2][3]
- -


Librerías externas incluidas

Una instalación de Joomla! contiene librerías externas que se incluyen con las versiones del CMS. Estas librerías externas no son parte del código del núcleo. Por favor lea la sección Notas, ya que puede contener más información, como el cambio en la versión de una librería externa con una versión de mantenimiento.

Librerías externas según la versión de Joomla

Versión del CMS Versión del CMS soportada Mootools Mootools More jQuery jQuery UI
(Core, Widget, Mouse, Position, and Sortable)
Bootstrap Simple Pie PHP Mailer PHP UTF-8 IDNA Convert Framework de Desarrollo Rápido de Extensiones (RAD)
Framework on Framework (FOF) de Akeeba
password _compat[4] lessphp random _compat[5]
2.5
X-mark.png
1.4.5[6] 1.4.0.1 N/A[7] N/A[7] N/A[7] 1.2 5.2.1 0.5 N/A[8] N/A[9] N/A[10] N/A[11] N/A[12]
3.0
X-mark.png
1.4.5 1.4.0.1 1.8.1 1.8.23 2.1.0 1.2 5.2.1 0.5 N/A[8] N/A[9] N/A[10] N/A[11] N/A[12]
3.1
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.1.0 1.2[13] 5.2.3 0.5 N/A[8] N/A[9] N/A[10] N/A[11] N/A[12]
3.1.2
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.3.2[14] 1.2[13] 5.2.6 0.5 0.8.0 N/A[9] N/A[10] N/A[11] N/A[12]
3.2
X-mark.png
1.4.5 1.4.0.1 1.10.2[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.6 0.5 0.8.0 2.1 1.0.3 N/A[11] N/A[12]
3.3
X-mark.png
1.4.5 1.4.0.1 1.11.1[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.8 0.5 0.8.0 2.1 1.0.3 N/A[11] N/A[12]
3.4
X-mark.png
1.4.5 1.4.0.1 1.11.3[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.9 0.5 0.8.0 2.4.3 1.0.4 0.3.9 N/A[12]
3.5
X-mark.png
1.4.5 1.4.0.1 1.11.3[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.0.10
3.6
X-mark.png
1.4.5 1.4.0.1 1.12.4[15] 1.9.2 2.3.2[14] 1.3.1[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.7
X-mark.png
1.4.5 1.4.0.1 1.12.4[15] 1.9.2 2.3.2[14] 1.3.1[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.8
Checkmark.png
1.4.5 1.4.0.1 1.12.4[15] 1.9.2 2.3.2[14] 1.3.1[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.9
4.0


Explicación de las versiones de Joomla!

Joomla! 
3.8.1
Versión Estable

Esta página ofrece un resumen de la estrategia de desarrollo actual publicada el 25 de abril de 2014. Todas las versiones de Joomla anteriores al 25 de abril de 2014 han sido desarrolladas siguiendo el antiguo ciclo de desarrollo y soporte. Deberías leer el texto completo del artículo estrategia de desarrollo de Joomla para una explicación más detallada.

Joomla! se desarrolla siguiendo Versionamiento Semántico (2.0.0). El uso de LTS (Long Term Support - Soporte de Larga Duración) y STS (Short Term Support - Soporte de Corta Duración) ya no es relevante. Los términos que se encuentran inmediatamente debajo serán usados para mayor claridad. Deberías entender estos términos y sus significados.

  • soportada - la última versión menor de una versión mayor recibirá parches que incluirán correcciones tanto de problemas generales como de seguridad
  • actual - la versión major.minor.patch más joven o reciente en relación a la fecha de lanzamiento oficial
  • obsoleta - cualquier versión major.minor.patch que no sea la actual[16]
  • estable - versión mayor lista para ser usada en sitios en producción, implícita en las versiones "actual" y "obsoleta"[17]
  • EOS - acrónimo para 'end of support (fin del soporte)', que indica que no se lanzarán más parches para solucionar problemas generales o de seguridad.
  • EOL - acrónimo para 'end of life (fin de vida útil)', que indica lo mismo que EOS[18]

Cada versión mayor de Joomla! recibe soporte del Proyecto Joomla!TM durante un espacio de tiempo limitado, contando desde la fecha en la que dicha versión es lanzada oficialmente. Joomla desarrollará activamente cada versión mayor durante un mínimo de 2 años. Esto puede ser seguido por el desarrollo continuo de una versión mayor según lo planificado en su hoja de ruta.[19]Un breve resumen sería:

  • cada versión mayor tendrá un mínimo de 4 años de soporte
  • siempre deberías usar o actualizar a la última versión minor.patch de la versión mayor estable
  • cada actualización de la versión menor que se lance será compatible hacia atrás con la versión menor previa[20]

Por favor usa la Hoja de ruta del desarrollo del CMS Joomla! o la tabla de Versiones del CMS Joomla! para determinar el EOS (fin de soporte) para cada versión major.minor o para la versión mayor al completo.

Explicación de la numeración de las versiones

Los identificadores de cada versión de Joomla siguen una convención numérica de tres niveles, en la que los niveles se definen por la importancia de los cambios en el software.

[major].[minor].[patch]

Estos tres niveles se definen como:

  1. Un incremento en el identificador de versión major (mayor) indica una ruptura de la compatibilidad hacia atrás.
  2. Un incremento en el identificador de versión minor (menor) indica la adición de nuevas características o un cambio significativo en características existentes.
  3. Un incremento en el identificador de versión patch (parche) indica que se han corregido fallos.

Ejemplos

Estás usando la versión 3.3.6 de Joomla. Esto significa que tu versión es versión mayor 3, versión menor 3, y versión parche 6. Si se lanza un parche para la 3.3.6, tu versión de Joomla se incrementaría a la 3.3.7. Si se lanza una nueva versión menor para la versión mayor 3, tu nueva versión de Joomla sería la 3.4.0. Esta página siempre mostrará la versión actual estable soportada de Joomla, incluyendo las versiones menor y de parche, en la esquina superior derecha.


Referencias y notas

  1. La corrección de problemas cesará en Abril de 2014, sólo parches de seguridad, consulta http://community.joomla.org/blogs/leadership/1798-raising-the-bar-on-security.html.

    "También, para los 6 meses posteriores al lanzamiento de Joomla 3.3, el proyecto Joomla liberará versiones de seguridad para las dos, 3.2 y 3.3 (así como para la 2.5), de modo que cualquier nueva vulnerabilidad pueda ser parcheada rápidamente con una actualización en un clic sin la necesidad de tener que actualizar a Joomla 3.3 inmediatamente, dándote tiempo para que pidas a tu proveedor de alojamiento que actualice su versión de PHP."

  2. 2.0 2.1 2.2 See J3's roadmap for time frames of all future releases of all Joomla! 3 versions.
  3. 3.0 3.1 Please note that dates may be subject to change depending on availability of volunteers and circumstances beyond the PLT's control.
  4. Esta biblioteca está destinada a proporcionar compatibilidad hacia adelante con las funciones password_* que se han añadido a PHP 5.5. Ver git de password_compat para más información.
  5. Esta librería está destinad a proporcionar compatibilidad hacia delante con las funciones random_bytes y random_int que fueron añadidas a PHP 7.0. Ver random_compat git para más información.
  6. Contiene una capa de compatibilidad con 1.2
  7. 7.0 7.1 7.2 No aplicable, esta biblioteca no estaba incluida en la versión 2.5 del CMS Joomla!.
  8. 8.0 8.1 8.2 No aplicable, esta biblioteca no estaba incluida en el CMS Joomla! en versiones anteriores a la 3.1.2.
  9. 9.0 9.1 9.2 9.3 No aplicable, esta biblioteca no estaba incluida en el CMS Joomla! en versiones anteriores a la 3.2. Sin embargo, la versión de FOF incluida en Joomla 3.2 es compatible con Joomla 2.5.
  10. 10.0 10.1 10.2 10.3 No aplicable, esta biblioteca no estaba incluida en el CMS Joomla! en versiones anteriores a la 3.2.
  11. 11.0 11.1 11.2 11.3 11.4 11.5 No aplicable, esta biblioteca no estaba incluida en el CMS Joomla! en versiones anteriores a la 3.4
  12. 12.0 12.1 12.2 12.3 12.4 12.5 12.6 No aplicable, esta biblioteca no estaba incluida en el CMS Joomla! en versiones anteriores a la 3.5
  13. 13.0 13.1 13.2 13.3 13.4 13.5 13.6 13.7 13.8 Esta librería está obsoleta y fue sustituida por JFeedFactory en la versión 3.1.0 del CMS Joomla!
  14. 14.0 14.1 14.2 14.3 14.4 14.5 14.6 14.7 Contiene algunos valores predeterminados de compatibilidad hacia atrás con la versión 2.1
  15. 15.0 15.1 15.2 15.3 15.4 15.5 15.6 Incluye el plugin jQuery Migrate 1.2.1 para compatibilidad hacia atrás
  16. Ten en cuenta que el término "obsoleta" se usa únicamente para designar el estado de una versión en relación a la actual. Los usuarios y desarrolladores deberían fijarse en la fecha EOS (fin de soporte) para determinar la viabilidad se seguir usando o no una versión marcada como obsoleta.
  17. Las versiones marcadas como alfa, beta o rc (release candidate - versión candidata) sólo deberían usarse para hacer pruebas.
  18. Se pueden usar EOS o EOL indistintamente. Cualquiera de ambos términos indica el 'fin del soporte' y nada más. No confundir el significado de 'EOL' con que el software dejará de funcionar.
  19. La explicación completa de las versiones soportadas puede encontrarse en el apartado 4.3 Supported releases del documento sobre la estrategia de desarrollo de Joomla (en inglés).
  20. Una extensión instalada en la versión major.0.x funcionará en la versión major.7.x. Las extensiones o plantillas son desarrolladas por terceros, y la publicación de sus actualizaciones son responsabilidad de cada desarrollador. La instalación de las actualizaciones de las extensiones o plantillas son responsabilidad del usuario.
Advertisement