Technische vereisten

From Joomla! Documentation

This page is a translated version of the page Technical requirements and the translation is 100% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎中文(台灣)‎

Meer informatie kan gevonden worden op Joomla!.

Joomla! 
3.x

Vereisten voor ondersteunde software

Vereisten voor Joomla 3.x Joomla 3.x

Software Aanbevolen Minimum Meer informatie
PHP (Magic Quotes GPC, MB String Overload = off / Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default) 5.6 + of 7 +[1] 5.3.10 + www.php.net
Ondersteunde databases:
MySQL[2] (InnoDB ondersteuning vereist) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
Ondersteunde webservers:
Apache(met mod_mysql, mod_xml, en mod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


Verwijzingen

  1. PHP 5.3.1 is vereist voor versies 3.0 tot en met 3.2. Bij 3.3 is de minimale versie verhoogd naar PHP 5.3.10.
    Alleen Joomla! versies 3.5 en later zijn compatibel met PHP 7.
  2. Joomla is nog niet compatibel met MySQL 6.x.
  3. Om gebruik te kunnen maken van zoekmachinevriendelijke URL's, moet de Apache mod_rewrite extensie geïnstalleerd zijn.
  4. De mod_suphp extensie of mod_fcgid extensie wordt aanbevolen om het mogelijk te maken om bestanden te uploaden en uit te voeren met behulp van veilige bestandsrechten.

Optionele eisen voor Joomla! 3.x

Enkele optionele technische eisen zijn geen vereisten om Joomlaǃ te installeren en draaien maar zijn noodzakelijk door afhankelijkheden om verschillende interne API's te ondersteunen.